升级到lighttpd 1.4.28-1碰到的问题

昨天在VPS上执行apt-get update,apt-get upgrade 升级时,在提示是否替换lighttpd的配置时全选yes后,出现所有网站无法访问,报403错误的问题。

检查lighttpd替换的配置,发现/etc/lighttpd/conf-available/fastcgi.conf 少了.php文件的部分。在新的配置文件里加入如下内容:

fastcgi.server    = ( “.php” =>
((
“bin-path” => “/usr/bin/php5-cgi”,
“socket” => “/tmp/php.socket”,
“max-procs” => 2,
“idle-timeout” => 20,
“bin-environment” => (
“PHP_FCGI_CHILDREN” => “4”,
“PHP_FCGI_MAX_REQUESTS” => “10000”
),
“bin-copy-environment” => (
“PATH”, “SHELL”, “USER”
),
“broken-scriptfilename” => “enable”
))
)

重启lighttpd后,故障排除。

发表评论

电子邮件地址不会被公开。 必填项已用*标注